标准检测方法与测定原理 (Analytical Principle)
分析方法库 (SOP)
的随流检测技术的数据内容及其IPv6 封装方法、SRv6 封装方法,符合 RFC93
标准适用范围与监测对象 (Scope)
................................................................................................................................4
1
修订条款
) IETF RFC2579 SMIv2 的文本约定(Textual Conventions for SMIv2) IETF RFC2580 SMIv2 的一致性声明(Conformance Statements for SMIv2) IETF RFC3410 互联网标准管理框架简介及适用性说明(Introduction and Applicability Statements for Internet Standard Management Framework) IETF RFC3418 简单网络管理协议(SNMP)的管理信息库MIB(Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)) IETF RFC6020 网络配置协议(NETCONF )YANG 数据模型(YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)) IETF RFC6241 网络配置协议(Network Configuration Protocol (NETCONF)) IETF RFC7011 用于交换流信息的IP 流信息导出(IPFIX)协议的规范(Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow Information) IETF RFC7012 IP 流信息导出(IPFIX )协议信息模型 (Information Model for IP Flow Information Export (IPFIX)) IETF RFC7013 IP 流信息导出(IPFIX)协议信息元素的作者和审阅者准则(Guidelines for Authors and Reviewers of IP Flow Information Export (IPFIX) Information Elements) IETF RFC7015 IP 流信息导出(IPFIX )协议的流聚合(Flow Aggregation for the IP Flow Information Export (IPFIX) Protocol) IETF RFC7950 YANG 建模语言(The YANG 1。
2
修订条款
1 Data Modeling Language) IETF RFC8549 IP 流信息导出(IPFIX)协议的BGP 团体属性导出(Export of BGP Community Information in IP Flow Information Export (IPFIX)) 4 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX IETF RFC8955 流规格规则的传播(Dissemination of Flow Specification Rules) IETF RFC8956 IPv6 流规格规则的传播(Dissemination of Flow Specification Rules for IPv6) IETF RFC9086 边界网关协议-用于分段路由BGP 出口对等工程的链路状态(BGP-LS)扩展 (Border Gateway Protocol-Link State (BGP-LS) Extensions for Segment Routing BGP Egress Peer Engineering) IETF RFC9256 分段路由策略架构(Segment Routing Policy Architecture) IETF RFC9341 交替标记方法(Alternate-Marking Method) IETF RFC9343 交替标记方法的IPv6 应用(IPv6 Application of the Alternate-Marking Method) IETF RFC9351 边界网关协议-用于灵活算法通告的链路状态(BGP-LS)扩展(Border Gateway Protocol-Link State (BGP-LS) Extensions for Flexible Algorithm Advertisement) 3 术语、定义和缩略语 3。
3
修订条款
1 术语和定义下列术语和定义适用于本文件。
4
修订条款
1 自智网络 Autonomous Networks 指通信网络数字化转型演进目标。面向客户提供“零等待、零故障、零接触”等体验的新型网络与ICT 服务,面向运维打造“自配置、自修复、自优化”等数智能力。
5
修订条款
2 自智网络分级 Autonomous Network Level 按照自动化实现程度,划分L0-L5 标准,为不同级别定义明确的、无歧义的技术成熟度代际特征与业务应用成效指标。
6
修订条款
3 意图 Intent 指对期望的规范定义,包括对系统的要求、目标和约束。
7
重要变更
4 闭环 Closed Loop 指自智网络系统中的一种机制,闭环使自治域能够基于感知、分析与决策调整其行为,以适应用户需求、业务目标或环境条件的变化。
8
修订条款
2 缩略语下列缩略语适用于本文件。 AI 人工智能 Artificial Intelligence BFD 双向转发检测 Bidirectional Forwarding Detection BGP 边界网关协议 Border Gateway Protocol BGP 边界网关协议流规则 BGP Flow Specification 5 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX FlowSpec BGP-LS 链路状态BGP BGP Link-State BMP 路由监控协议 BGP monitoring protocol ECMP 等价负载分担路径 Equal-Cost Multiple Path EPE 出口对等工程 Egress Peer Engineering IGP 内部网关协议 Interior Gateway Protocol IPFIX IP 流信息导出协议 IP Flow Information Export LDP 标签分发协议 Label Distribution Protocol LLDP 链路层发现协议 Link Layer Discovery Protocol MP-BGP 多协议边界网关协议 Multi-Protocol BGP MPLS 多协议标签交换 Multi-Protocol Label Switching OSPF 开放最短路径优先 Open Shortest Path First QOS 服务质量 Quality of Service SBFD 无缝双向转发检测 Seamless Bidirectional Forwarding Detection SNMP 简单网络管理协议 Simple Network Management Protocol SRH IPv6 分段路由头部 Segment Routing Header SRv6 IPv6 数据面的分段路由技术 Segment Routing Over IPv6 TWAMP 双向主动测量协议 Two-Way Active Measurement Protocol UCMP 非等价负载分担路径 Unequal-Cost Multiple Path 4 自智网络概述自智网络的闭环框架见图1。数据承载网络的自智主要完成数据承载网的单域自智,实现数据承载网的资源运营和资源闭环。本文件中数据承载网络包括数据承载网络设备和控制器。
9
修订条款
6 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX 图1 自智网络的闭环框架 YD/T 4833-2024 规定的信息通信网运营管理通用流程见图2。虚线框在本文件中指数据承载网络控制器,被管对象在本文件中指路由器等数据承载网络设备。其中感知和执行两个流程涉及数据承载网络控制器和数据承载网络设备之间的交互,本文件也主要从这两个流程分析自智网络对数据承载网络的能力要求。 图2 信息通信网运营管理通用流程 YD/T 4833-2024 根据各类别管理流程中相关人员与信息通信系统的参与程度高低制定的网络运营管理智能化水平分级通用方法见表1。从2 级(下文简称L2)开始所有执行类的任务都由信息通信系统自动完成,且目前数据承载网络均能满足0 级和1 级的技术要求,因此本文件不再对0 级和1 级进行能力分析和技术要求;
10
修订条款
5 级要实现全智能化运营管理,其内涵和外延还在不断发展中,数据承载网络应具备的能力和技术也在不断演进中,本文件也不对5 级进行规定和要求。
11
修订条款
2 级、3 级(下文简称 L3)、4 级(下文简称L4)分别对应初级、中级、高级智能化运营管理,数据承载网络分别应具备的技术能力、应满足的技术要求是本文件的重点内容。 表1 信息通信网运营管理智能化水平分级的通用方法信息通信网运营管理智能化水平级别通用流程执行感知分析决策意图管理 0 级人工运营管理人工人工人工人工人工 1 级辅助运营管理人工+信息通信系统人工+信息通信系统人工人工人工 2 级初级智能化运营管理信息通信系统人工+信息通信系统人工+信息通信系统人工人工 3 级中级智能化运营管理信息通信系统信息通信系统人工+信息通信系统人工+信息通信系统人工 4 级高级智能化运营管理信息通信系统信息通信系统信息通信系统信息通信系统人工+信息通信系统 5 级全智能化运营管理信息通信系统信息通信系统信息通信系统信息通信系统信息通信系统 7 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX 注:对于所有等级的网络运营管理智能化水平,当人工审核后的决策与信息通信系统生成的决策存在冲突时,人工审核的决策具有最高权限。 其中: ——“人工”表示相应的管理任务由人或者人使用网络运营管理工具来完成;
12
修订条款
——“人工+信息通信系统”表示相应的任务由人和信息通信系统共同完成,具体人和系统的协同方式在总体方法中未指定,要根据具体用例来描述;
13
修订条款
——“信息通信系统”表示相应的管理任务由信息通信系统完成。
14
修订条款
5 数据承载网络自智水平分级能力要求 5。
15
修订条款
1 概述结合YD/T 4833-2024 中的流程和分级方法,本文件主要从网络运营和网络维护两个角度对数据承载网络的自智能力进行规范。网络自运营主要关注业务自动开通与差异化服务,满足不同业务差异化需求;网络自维护主要关注网络故障自排除与网络性能自优化,满足网络运维效率提升需求。网络运营和网络维护的典型场景见附录A。 数据承载网络控制器的分级技术要求见YD/T 4835-2024。针对本文件规定的数据承载网络设备的北向接口技术要求,在相应级别下,控制器也应具备对网络拓扑、运行状态、性能参数、故障事件等数据的感知及信息的采集能力,对数据和信息进行处理分析的能力,将处理分析结果下发到网络设备的配置能力,和网络设备配合完成网络自运营和自维护。
16
修订条款
2 网络运营自智化分级能力要求数据承载网络在网络运营方面的自智化能力要求见表 2。 表 2 数据承载网络运营自智化分级能力要求网络运营活动及任务自智化能力要求自智化能力分级 L2 L3 L4 感知 (基于运营任务的数据收集) 设备支持人工完成基于运营任务的数据收集: 设备支持人工使能采集开关,响应管控采集指令, 完成数据快速获取并上报结果。 设备支持采集的数据包括 SNMP 接口相关的设备配置、网络拓扑、设备状态等。 设备自动响应感知任务: 设备根据管控系统使能和采集指令,完成数据快速感知并上报结果,在L2 基础上,设备感知信息更精细和精确,支持自动按需根据本地差异化监控模板使能自感知任务: 拓扑感知可获取网络流量工程相关信息。 性能感知支持网络质量在线测量,可获取隧道的时延、抖动、丢包率等。 设备自动响应感知任务: 设备根据管控系统使能和采集指令,完成数据秒级感知并上报结果, 在L3 基础上,设备感知信息更为全面: 支持切片拓扑、状态、 性能感知。 支持业务性能感知。
17
修订条款
8 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX 支持网络流量流向感知。 执行 (运营动作执行并验证) 设备支持系统调用执行业务开通等运营动作,支持人工验证执行结果。 在L2 基础上,提供业务差异化服务能力,提供业务控制面隔离能力,支持系统自动验证执行结果。 在L3 基础上,提供业务转发面隔离能力。 在感知数据基础上自动完成业务调优。 对于网络运营所需的业务自动发放和质量保障,根据YD/T 4835-2024 定义,数据承载网络控制器L3 能力应支持自动化的采集和执行;L4 在L3 级基础上,还应支持业务意图接口,并在业务发放前针对业务相关的设备配置数据进行智能仿真验证,业务发放中支持失败回滚,业务发放后支持自动化业务验证以及持续的优化,从而保障业务全生命周期的SLA。
18
删除淘汰
3 网络维护自智化分级能力要求数据承载网络在网络维护方面的自智化能力要求见表 3。 表 3 数据承载网络维护自智化分级能力要求网络维护活动及任务自智化能力要求自智化能力分级 L2 L3 L4 感知 (基于维护任务的数据采集) 设备支持人工完成基于维护任务的数据收集: 设备支持人工使能采集开关,响应管控采集指令, 完成数据快速感知并上报结果。 设备支持采集的数据包括管理面数据、控制面数据、转发面数据,如网络拓扑、设备状态、网络性能、设备性能、流量流向、告警信息、诊断信息等。 设备自动响应感知任务: 设备根据管控系统使能和采集指令,完成数据快速感知并上报结果,在L2 基础上,设备感知信息更精细和精确: 拓扑感知可获取网络流量工程相关信息。 性能感知支持网络质量在线测量,可获取隧道的时延、抖动、丢包等。 可获取路由信息及路由协议状态。 设备支持采集任务定制功能,包括采集任务的创建、查询、修改和删除, 采集数据查询、订阅和发布。 设备自动响应感知任务,支持自动选择本地预置差异化和精细化监控模板,分解和启动监控任务: 设备根据管控系统使能和采集指令,完成数据快速感知并上报结果, 在L3 基础上,设备感知信息更为全面,支持自动按需根据本地差异化监控模板使能自感知任务: 支持切片拓扑、状态、 性能感知。 支持业务性能感知。 执行 (维护动作执行并验证) 设备支持系统调用执行维护动作,支持人工验证执行结果。 设备在L2 基础上支持回滚。 设备在配置下发后自动向控制器反馈执行结果。 支持切片自动配置。
19
修订条款
9 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX 对于网络维护所需的故障定位和故障修复,根据YD/T 4835-2024 定义,数据承载网络控制器L3 能力应支持自动化的数据采集和配置;L4 在L3 级基础上,还应支持网络维护意图接口,控制器自动完成基于AI 的网络异常识别;基于随流检测与AI 进行告警的压缩和聚合,实现业务群障自动识别和智能故障修复建议等功能。
20
修订条款
6 数据承载网络自智水平分级技术要求 6。
21
修订条款
1 概述为满足上述数据承载网络不同自智级别的能力要求,本章节分别从管理面、控制面和数据面维度给出数据承载网络在每个自智级别应满足的具体技术要求及应遵循的标准规范。数据承载网络不同自智级别的技术要求为递进关系,即数据承载网络高级别自智在满足低级别自智技术要求基础上,应增量支持高级别自智技术要求。如:L4 级别自智能力应同时满足L2 及L3 自智级别技术要求。 6.2 L2 自智级别技术要求 6。
22
修订条款
1 管理面技术要求应用于L2 自智级别数据承载网络,管理面应支持: a) 物理拓扑感知: 1) 设备应支持LLDP 链路层发现协议,交互相邻设备的名称、型号、版本、MAC 地址、IP 地址等信息; 2) 设备应支持SNMP 上报设备软硬件信息以及LLDP 相邻设备信息。 b) 路由拓扑感知: 1) 设备应支持BGP-LS 上报IGP 节点、链路及前缀等路由拓扑信息; 2) 设备应支持IPv4、IPv6 路由拓扑信息上报。 c) 网络故障感知: 1) 设备应支持SNMP trap 上报设备告警,包括单板离线/上线、CPU 负载过高、接口 down/up、BGP Peer down/up、接口流量利用率过高、链路质量劣化、VPN 路由超限等告警; 2) 设备应遵循RFC2578,RFC2579,RFC2580,RFC3410 到RFC3418 标准中规定的 SNMPv2 和SNMPv3,进行网管配置时支持优选较高版本。 d) 网络性能感知: 设备应支持SNMP 上报性能数据,包括CPU 和内存利用率、端口流量统计等性能数据。 e) 网络流量感知: 设备应支持IPFIX 等流量采集协议,上报接口入出方向IPv4、IPv6 和MPLS 采样流量的统计信息。采集报文遵循RFC7011、RFC7012、RFC7013、RFC7015、RFC8549。 f) 流量调优: 设备应支持从控制器接收BGP FlowSpec 路由,匹配公网IPv4、IPv6 流量的报文头部信息, 执行重定向到指定IP 下一跳、指定VRF 等调优动作。BGP FlowSpec 应遵循 RFC8955、RFC8956。 g) 业务诊断: 设备应支持Ping 和Trace 功能,对IPv4、IPv6 和MPLS 场景的网络连通性进行诊断。
23
修订条款
2 控制面技术要求 10 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX 应用于L2 自智级别数据承载网络,设备控制面应支持传统OSPF、OSPFv3、MP-BGP、LDP 等路由协议。
24
修订条款
3 数据面技术要求应用于L2 自智级别数据承载网络,设备数据面应满足IPv4 和IPv6 业务,及MPLS 业务转发。 6.3 L3 自智级别技术要求 6。
25
删除淘汰
1 管理面技术要求应用于L3 自智级别数据承载网络,管理面应支持: a) 物理拓扑感知:设备应支持NETCONF 上报设备软硬件信息以及LLDP 相邻设备信息; b) 路由拓扑感知:设备应支持BGP-LS 上报IGP 链路扩展TE 度量,包括丢包、时延、抖动、 已用带宽和可用带宽等; c) 路由状态感知:设备应支持BMP 上报BGP Peer Up/Down 状态以及统计信息、IPv4/IPv6 地址簇RIBin 路由、VPNv4/VPNv6 地址簇RIBin 路由、VRF IPv4/IPv6 地址簇RIBin 路由等; d) 网络故障感知:设备应支持NETCONF 上报设备告警,包括单板离线/上线、CPU 负载过高、 接口down/up、BGP Peer down/up、接口流量利用率过高、链路质量劣化、VPN 路由超限、SRv6/G-SRv6 Policy 隧道down/up 等告警; e) 网络性能感知:设备应支持NETCONF 部署轻量级TWAMP 检测任务,支持轻量级 TWAMP 对物理链路、Trunk 成员链路、L3VPN 业务端到端场景测量丢包率、时延、抖动等性能指标检测: 1) 设备应支持NETCONF 静态订阅Telemetry 数据采集,通过Telemetry 上报性能数据, 包括CPU 和内存利用率、端口流量统计、SRv6/G-SRv6 Policy 隧道流量统计、轻量级 TWAMP 测量结果、随流检测流量统计以及时戳信息等性能数据; 2) 设备应支持NETCONF 协议,遵循RFC6241。设备支持YANG 模型,遵循 RFC6020、RFC7950; 3) 设备应支持时钟时间同步。支持通过主控板BITS 接口同步时钟频率,支持通过业务板以太接口同步以太网或PTP 同步时钟频率。支持通过主控板BITS、GPS 或PTP 接口同步时间。 f) SRv6/G-SRv6 资源感知:设备应支持SRv6/G-SRv6 资源感知,支持BGP-LS 上报 SRv6/G-SRv6 资源信息,包括SRv6 位置标识、END/END.X SID 以及Flavor 信息、SRv6 SID 结构、END/END.X G-SID 以及特性信息、跨域链路SRv6 BGP EPE (Egress Peer Engineering) SID/G-SID 信息、Trunk 成员口SRv6 END.X SID/G-SID 信息等; g) SRv6/G-SRv6 隧道管理:设备应支持基于NETCONF+BGP SR Policy 的SRv6/G-SRv6 Policy 隧道的创建、修改、查询和删除;支持BGP-LS 上报SRv6/G-SRv6 Policy 的备份路径和段列表信息和状态; h) SRv6 VPN 业务管理:设备应支持基于NETCONF 的L3VPN/L3EVPN/L2EVPN 实例、接口、 接入协议、隧道、QoS、保护等参数的创建、修改、查询和删除; i) SRv6 流量调优:设备应支持从控制器接收BGP FlowSpec 路由,匹配公网IPv4、IPv6 流量的报文头部信息,执行重定向到SRv6 BE、SRv6/G-SRv6 Policy 等调优动作; j) SRv6 业务诊断:设备应支持基于NETCONF 的SRv6/G-SRv6 Ping 和Trace 任务管理和结果上报;支持基于NETCONF 的SRv6/G-SRv6 随流检测任务管理; k) 网络协议感知:设备应支持BMP BGP 运行状态采集,用于管控系统的分析决策。
26
修订条款
11 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX 6。
27
修订条款
2 控制面技术要求应用于L3 自智级别数据承载网络,设备控制面应支持: a) 扩展TE 度量: 1) 设备应支持扩展TE 度量相关的IGP 协议扩展; 2) 设备应支持IGP 链路的丢包率、时延、抖动、已用带宽和可用带宽等扩展TE 度量信息通告和泛洪。 b) SRv6/G-SRv6: 1) 设备应支持SRv6/G-SRv6 相关的IGP 协议扩展; 2) 设备应支持SRv6 位置标识、END/END.X SID/G-SID 以及特性信息通告、泛洪及路由计算; 3) 设备应支持SRv6 TI-LFA FRR 路径计算和生成,支持SRv6 防微环路径计算和生成。
28
修订条款
3 数据面技术要求应用于L3 自智级别数据承载网络,设备数据面应支持: c) SRv6/G-SRv6 多业务承载: 设备应支持SRv6 BE 承载公网IPv4/IPv6 业务、L3VPN/L3EVPN IPv4/IPv6 业务以及 L2EVPN 业务。 d) SRv6/G-SRv6 负载分担: 1) 设备应支持SRv6 BE、SRv6/G-SRv6 Policy 流量在Trunk 成员链路之间负载分担; 2) 设备应支持SRv6 BE、SRv6/G-SRv6 Policy 流量在ECMP/UCMP 成员链路之间负载分担; 3) 设备应支持SRv6/G-SRv6 Policy 流量在ECMP/UCMP 成员段列表之间负载分担。 e) SRv6/G-SRv6 可靠性保护: 1) 设备应支持SRv6 BE、SRv6/G-SRv6 Policy 路径松散段的TI-LFA FRR 本地保护; 2) 设备应支持SRv6/G-SRv6 Policy 基于主备候选路径的双机热备端到端路径保护; 3) 设备应支持SRv6/G-SRv6 公网/L3VPN/L3EVPN/L2EVPN 业务基于主备PE 的VPN FRR 保护; 4) 设备应支持BFD、SBFD 检测网络故障,支持链路故障、路径故障和出PE 故障的检测; 5) 设备应支持SRv6/G-SRv6 流量统计; 6) 设备应支持SRv6/G-SRv6 Policy 流量统计。 6.4 L4 自智级别技术要求 6。
29
修订条款
1 管理面技术要求应用于L4 自智级别数据承载网络,管理面应支持: a) 网络切片拓扑资源感知: 1) 设备应支持基于BGP-LS 的网络切片拓扑感知; 2) 设备应支持BGP-LS 的EPE 扩展,符合RFC9086 的要求; 3) 设备应支持BGP-LS 的灵活算法扩展,符合RFC9351 的要求。 b) 网络切片性能感知: 设备应支持对IP 网络切片的时延、抖动、丢包率、速率的性能检测,检测结果支持 Telemetry 订阅与秒级(如30s)上报。 c) 网络切片故障管理: 1) 设备应支持对切片告警进行持续或间断的监测;
30
重要变更
12 std.miit.go std.miit.go std.miit.go YD/T XXXXX—XXXX 2) 设备应支持告警的产生和清除; 3) 设备应支持切片故障定位; 4) 设备应支持切片告警日志的记录和查询。 d) 网络切片配置和优化: 1) 设备应支持NETCONF 配置网络切片,包括EVPN、MVPN 等软切片,FlexE 切片,逻辑子端口切片; 2) 设备应支持切片带宽无损调整。 e) 随流检测配置与感知: 1) 设备应支持NETCONF 配置随流检测实例,包括公网随流检测和VPN 随流检测; 2) 设备应支持随流检测结果Telemetry 订阅与秒级(如30s)上报。 f) 应用感知: 1) 设备应支持实时智能流识别,如时延敏感应用流量,DDOS 流等; 2) 设备应支持精细化的流量调优,安全管理等策略。 g) 光模块硬件故障感知: 设备应支持智能光模块光功率实时毫秒级监测与预警。 h) 故障修复: 设备应支持对IP 网络切片业务的故障检测,并支持IP 网络切片故障快速倒换功能,可以实现物理层、链路层、网络层的故障快速倒换机制,物理层、链路层故障倒换时间小于200ms, 网络层故障倒换时间小于500ms。 i) QoS 策略执行: 设备应支持AI-Qos 调优,适应灵活的流量模型 j) 安全策略: 1) 设备应支持和防止切片间的网络攻击及安全威胁检测; 2) 设备应支持网络攻击监测防护、访问控制和流量控制,抗攻击功能。
核心起草科研机构与龙头企业矩阵:
中国移动通信集团有限公司中国信息通信研究院中兴通讯股份有限公司华为技术有限公司中国信息通信科技集团有限公司新华三技术有限公司中盈优创资讯科技有限公司中国电信集团有限公司